BricsCAD Version 19.2.15 (x64) on Debian 10


how can i open files from my network like

afp://baubuero@WD-4TB-BAUBUERO.local/baubuero/ ??

Thanks for help!!


  • navnav
    edited January 2020

    I've just tried to open a file on an SFTP server mounted via gvfs and I get an error:

    But I've found a way around this: by creating a symlink to the network folder on my local file system:

    ln -s /path/to/network/folder ~/some/destination/path/on/local/filesystem

    A symlink is really just a shortcut to a file/folder that works across different file systems.

    You'll need to ensure that your server is mounted to some local path. I have mounted mine via nautilus (Ubuntu's file explorer) which supports SFTP and AFP (amongst others), which uses GVFS. For me, I can find my mounted locations in /run/user/1000/gvfs.

  • Michael Mayer
    edited January 2020

    I have my network Folders added to Favorites.
    But depending on which Linux Distribution (e.g. Open Suse)
    that may not help.
    As Favorites/Places Links will not work as long as such an external
    Drive/Folder is not mounted.
    So in Tumbleweed I have to open/mount (with password) from
    File Browser first, before I can access such Folders from Bricscad
    or similar Apps Open File Dialogs.

    Distributions like Elementary or MX Linux instead will just open
    external Drives from Favorites, without asking.

  • afp:// Apple File Protocol. I would be temped to install SAMBA server. is it only BricsCAD having trouble opening files? Or is it more general?

  • I think it is more general.
    some Linux App limited file open dialogs just don't
    offer to show all locations as File Browsers do.

    And even if you can reach such Folders from there, by Favorites
    links or similar, on Tumbleweed, I have to mount such network
    locations from the file manager first before those links work,
    (While ElementaryOS or Manjaro allow users to mount such
    external drives without need of root password)

  • We use SSH as well for network access at our office and it has always worked perfectly with BricsCAD, but you must use SSHFS (fuse) on the client computer(s) and mount your network drive (preferably by defining a mount point in '/etc/fstab') so that it is presented as a regular drive to your system. Expecting applications to use SFTP to open/save files seems odd. Your file manager perhaps shows your SFTP remote directory in a native-looking manner, but that does not mean you have a mounted network drive. Plain SFTP is meant for file transfer only.

  • In a general multi OS setting I would prefer SAMBA, in a Linux/Unix only environment I would prefer NFS. Both work splendid. @Mikael Nordvall, is SSHFS a historical choice? Just curious.

  • We started using SSH(FS) because of its security and flexibility. It is very easy from a maintenance perspective to only use one protocol for all our needs:
    Accessing network drives from within our LAN.
    Accessing network drives over the internet.
    Remote login for admins.
    The ability to do synchronizations and backups with unison and rsync over SSH.
    Tunneling remote desktops.
    Accessing network drives using SFTP from smartphones and tablets.
    Allowing administrative staff/consultants restricted access to specific directories over the internet with SFTP and a simple client like Filezilla.

    So far we have not been limited by any performance bottlenecks while scaling up the number of users. If we ever do in the future, then I guess we would mix SSH with NFS.

Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!