Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

All "Visual Style's" except "2dWireFrame" is are utilizing the processing power of my GPU

I draft in "2dWireFrame" as my visual style.

I installed Bricscad 20 (Version 20.2.10 (x64) revision 83907) on a new PC I just build.

My old PC had an integrated graphics card on the motherboard and zoomed fine on larger drawings... this one is horrendous.

I discovered, with the help of some software/hardware profiling tools, that the horse power of my new GPU is not being leveraged in "2dWireFrame".

When I zoom in "2dWireFrame" I see a stuttering and my GPU is under 10%, like 1%-3% when I just tested it now (see video example below).

Video example screencast of slow zoom on my new PC

Here's the kicker... All other "Visual Styles" ZOOM EXCELLENT (ie.. wireframe, sketch, xray, etc).

1) Can I get my 2dWireFrame to zoom like those other "Visual Styles", if so what do I need to do?
2) Can I create my own "2dWireFrame" like Visual Style that has a setting that leverages the video card like the other visual styles?

Help asap would be appreciated, thank you all.

Comments

  • edited April 15

    Another issue I realized is that my draw order in "2dWireFrame" is good.
    But my draw order in "WireFrame" is affected and not what it is in "2dWireFrame", why?

  • edited April 15

    Update video example of switching between visual styles

    @ 30 seconds in I switch from "2dWireFrame" to "WireFrame"... that's where it starts zoom well.

    GPU is at 1%-3% on the 2dWireFrame usually and then 20%+ on the other visual styles that run smooth.

  • Pity, going to OpenGL "Wireframe" Mode would have been my first advice.

    What is your dedicated GPU exactly now ?
    Have you set Bricscad in Windows Graphics Settings to full power
    and or suitable Energy Saving Settings ?

    Beside, I think that is a pretty complex file.
    Are the Hatches still intact or somehow exploded into single objects ?
    But strange that it worked well with a weak integrated GPU before.

    And by the way, if "2D Wireframe" isn't using GPU acceleration,
    what is your current CPU ?

  • Another idea,
    are you far from internal Origin ?
    Would it tun better if you try to center everything to 0,0,0 ?

  • REDSDKINFO

    RedSDK version: 4.4 (build 8)
    RenderUsingHardware: Hybrid hardware/software mode with preferred hardware rendering.
    OpenGL window creation succeeded.
    Operating system: Win_ten64
    Desktop composition (Aero) is enabled.
    Local GPU:
    GPU information:
    name: 'Unknown NVIDIA graphics adapter'
    chipset: ''
    class: 'HW_NVIDIA_GENERIC'
    asicID: '0x1f0a'
    vendorID: '0x10de'
    recommended driver: unknown
    Installed driver:
    driver: 'NVIDIA Forceware 465.89'
    dll version: ''
    This driver is newer than all internal known revisions.
    validation: 'Ok, newer'
    Selected GPU (created for GPU check):
    Chipset: HW_NVIDIA_G400
    Vendor: NVIDIA Corporation ( IsNVidia )
    OpenGL version: 4.6.0 NVIDIA 465.89
    Renderer: NVIDIA GeForce GTX 1650/PCIe/SSE2
    OpenGL extensions: GL_AMD_multi_draw_indirect GL_AMD_seamless_cubemap_per_texture

    (truncated the list of OpenGL because it was so long)

  • OK, a Nvidia GTX 1650.
    And it looks like you have the latest driver installed, directly from Nvidia
    (and not just something from Windows Update ...)

    Nvidia Control Center also offers custom Graphic Settings for each
    individual App. Some CAD Apps offer recommended Settings to
    de/activate certain options.
    But no clue fror Bricscad.

    I would file a Service Request, I am sure they could help.

    This looks a bit strange :

    GPU information:
    name: 'Unknown NVIDIA graphics adapter'
    chipset: ''
    class: 'HW_NVIDIA_GENERIC'

  • What is your dedicated GPU exactly now ?

    Nvidia GTX 1650

    Have you set Bricscad in Windows Graphics Settings to full power
    and or suitable Energy Saving Settings ?

    Power setting plan is on high performance. I did not see a specific program setting though.

    And by the way, if "2D Wireframe" isn't using GPU acceleration,
    what is your current CPU ?

    CPU - 2dWireframe - 11% ish
    CPU - WireFrame - 3-6%

    Nvidia Control Center also offers custom Graphic Settings for each
    individual App.

    Interesting I did not see anything for a specific app in their control center. I did see a non-gaming version of the drivers like a creator's version of it, tried it and then rolled it back when it didn't work.

  • I would file a Service Request, I am sure they could help.

    Where do I go to do that?

  • @Oz Bratene said:

    I would file a Service Request, I am sure they could help.

    Where do I go to do that?

    At the bottom right of Bricscads Website, "My Account", "My Support Requests

    "https://www.bricsys.com/protected/support/GetCustomerSupportRequests.do?statusID=1000

  • edited April 16

    Power setting plan is on high performance. I did not see a specific program setting though.

    I am not so experienced in Windows but I was able to add specific Apps
    in Windows Graphic (advanced ?) Options.
    I think I also set or added all my 3D and CAD Apps in Nvidia Control Center
    at that time. Meanwhile Iswitched to an AMD GPU.

  • I cannot really follow - 2dWireframe is an unaccelerated video mode, that works even with unsupported graphics devices. While its speed does depend on the 2d-vector performance of the graphics hardware, it can by design not leverage hardware acceleration (OpenGL).
    The problem is that it is the only mode that has draworder governed by object ID, while all other modes occlude geometry based on z-depth.
    I do not know if an accelerated mode that honors draworder by ID is possible, but it would definitely be a big leap forward for heavy drafting projects.

  • edited April 17

    2dWireframe is an unaccelerated video mode, that works even with unsupported graphics devices. While its speed does depend on the 2d-vector performance of the graphics hardware, ...

    Is it only GPU 2D Vector performance, or does it also depend
    on CPU (single core boost) speed ?
    (That is why I asked about which CPU is used)

  • Given the unique and important status and technology of 2dWireframe vs all the others, and the importance of it in ways that seem to keep multiplying, I think there should be a Help article all about it, as well as e.g. an instruction in every video tutorial to set Visualstyle appropriately for the task.

    The inaccuracy of 'the others' is significant and troublesome - I find my 3D modelling full of snaps which seemed good but actually missed and I frequently drop back to 2dWireframe to put things right - laborious.

  • Maybe playing with GLSWAPMODE could help.

    According to Settings, "GsDeviceType2D" is also using OpenGL
    The only other option would be RedSDK, which is not recommended.

    Not sure if OpenGL in 2DWireframe is only used for parts like cursor
    display, Snaps, ... and such or if it is using GPU hardware or just by
    Software on CPU.

    Nevertheless it is strange that it was ok with the weaker older machine
    and now does lag with the better hardware and dedicated GPU.

  • edited April 26

    Hopefully, the latest updated release will fix it.

  • @craigswearingen said:
    TESTGSFLAGS might be the solution. Change the setting from "0" to "6".
    Please note, you have to do REGEN after TESTGSFLAGS was changed.
    Or close and reopen the drawing.

    @craigswearingen
    can you explain what is TESTGSFLAGS variable?
    Thanks,
    Ari.

  • edited April 21

    I also have not found TESTGSFLAGS in DuchDuckGo, Bricscad Help, Commandline nor Settings.

  • edited April 26

    Hopefully, the latest updated release will fix it.

Sign In or Register to comment.
Origami
Origami is the Japanese word for paper folding. ORI means to fold and KAMI means paper and involves the creation of paper forms usually entirely by folding.

Powered by VanillaForums, Designed by Steam