Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Disabling auto zoom

Hi All,

I have BricsCAD Pro V20.1.04.
The issue is as follows:
* Double click a single line text to edit it
* Zoom in whilst it is editable
* Make the required text change and left click model space to finish editing it
* It will then automatically zoom out to where it was before I double clicked the text

This auto-zooming out is always throwing me out as I am used to constantly zooming and panning quickly as my hand wills it.
I have seen this post but not sure if it is exactly the same thing (I was able to disable auto-rotate) https://forum.bricsys.com/discussion/15565/any-way-to-edit-text-without-the-automatic-zoom
Also, on an older version of Bricscad, I am sure I was able to disable it but cannot for the life of me find it in the settings.
I think it was the setting attached, but I have tried 0 and 1 to no avail.

Any help here would be appreciated.

Cam.

bricszoom.png
833 x 618 - 31K

Answers

  • Single line text or multi-line text. Your post says single line, but the attachment is for multi-line.

  • Yes, my issue is with single line text.
    I just showed the multi-line zoom option as I could not find any option related to single line text and though maybe it would encompass both.

  • Try TEXTED to set the DTEXT editor. Not sure about zooming. I wrote my own in-place editor for DTEXT before an in-place editor was built-in to Bricscad so I don't use the built-in editor.

  • To disable auto-zoom during mtext editing, set MTEXTFIXED = 0 or 1.

  • Thanks guys for the suggestions.
    I have tried both ideas however it hasn't solved my particular issue.
    I'll keep looking into it and see if I can find out what warrants this behaviour and report back.
    Any other suggestions that come my way in the meantime, I will try everything.

  • @CSM said:
    Thanks guys for the suggestions.
    I have tried both ideas however it hasn't solved my particular issue.
    I'll keep looking into it and see if I can find out what warrants this behaviour and report back.
    Any other suggestions that come my way in the meantime, I will try everything.

    Try setting TEXTED = 1. This will bring up a dialogue to edit the single line text string in.

    Regards,
    Jason Bourhill
    BricsCAD V20 Ultimate
    CAD Concepts

Sign In or Register to comment.
Origami
Origami is the Japanese word for paper folding. ORI means to fold and KAMI means paper and involves the creation of paper forms usually entirely by folding.

Powered by VanillaForums, Designed by Steam