Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

V20 was OK, but V21 is a total disaster

For years we've used the Acad Lt versions for all our lay-outs in projects. Production was already in 3D via Creo software, but for 2D lay-outs we did it all in 2D.
Now we've moved from Acad Lt to Bricscad, after I used Bricscad V20 for several months. I had to make a 3D lay-out as a presentation was needed for a big offer. With no experience in 3D, I drawed the whole thing. Everything felt intuitive, so the managment agreed to make the change to Bricscad. We all use now the V21 and it's a disaster. I can hardly open any drawing without dealing with slow computers, freezing screens, messages 'not responding', ...
It's clear to me that V21 was not ready for introduction.
This post is no question. It's just a way to put my frustrations in.

Comments

  • I'm assuming you are on Windows 10 as I ran into this as well recently.

    Are you on a laptop with a dedicated graphics card? Until recently, with e.g. an nVidia graphics card, the control panel of the graphics card could be used to force an application to use the dedicated graphics card. Now it is fully controlled by Windows 10 but unfortunately it did not copy the settings from the graphics card control panel so you need to set it all over again in Windows 10.

    1. Right mouse click on the desktop and select Display Settings from the pop-up menu.
    2. In the Display dialog scroll all the way down and select "Graphics settings"
    3. In the Graphics performance preference set the choice to desktop app and then click on the browse button to select BricsCAD v21
    4. When the app shows up click on the options button that shows up underneath the app name and set the graphics preference to "High Performance"
    5. Press the save button to store this setting.

    That should force Bricscad to use the dedicated graphics card instead on the on CPU graphics. Graphics performance should then be improved (depending on the dedicated graphics card)

    Rinse and repeat for any other application that you want to force using the dedicated graphics card.

  • @RSW said:
    I'm assuming you are on Windows 10 as I ran into this as well recently.

    Are you on a laptop with a dedicated graphics card? Until recently, with e.g. an nVidia graphics card, the control panel of the graphics card could be used to force an application to use the dedicated graphics card. Now it is fully controlled by Windows 10 but unfortunately it did not copy the settings from the graphics card control panel so you need to set it all over again in Windows 10.

    1. Right mouse click on the desktop and select Display Settings from the pop-up menu.
    2. In the Display dialog scroll all the way down and select "Graphics settings"
    3. In the Graphics performance preference set the choice to desktop app and then click on the browse button to select BricsCAD v21
    4. When the app shows up click on the options button that shows up underneath the app name and set the graphics preference to "High Performance"
    5. Press the save button to store this setting.

    That should force Bricscad to use the dedicated graphics card instead on the on CPU graphics. Graphics performance should then be improved (depending on the dedicated graphics card)

    Rinse and repeat for any other application that you want to force using the dedicated graphics card.

    Thanks,
    We will try that.

  • edited January 10

    I have used AutoCAD for 10+yrs and I just bought Bricscad Pro v21 and I want to learn 3d. I can not find and Bricscad manual on 3d, I see that their is a lot of similarity between the two, do you think AutoCAD manual will be very helpful?

  • @tomcad143
    Yes, most commands in acad work in bcad, like.... all of them.
    3d modeling in acad/bcad is a matter of manipulating the current UCS.
    I like to draw a cube and use the UCS, Face command to pick a face.
    Then draw as normal, rotate, move, whatever.
    Then use the objects you are actually modeling to set the UCS.
    If you are not great at drawing in 2d in cad though, you have 2 learning curves...

Sign In or Register to comment.
Origami
Origami is the Japanese word for paper folding. ORI means to fold and KAMI means paper and involves the creation of paper forms usually entirely by folding.

Powered by VanillaForums, Designed by Steam