Unable to Save File

Hi,
I'm a new user of BricsCAD. I'm trying to save a file, however I keep getting an error as follows:
"ERROR: Failed to save the file.
Object of class AcDbDictionaryVar can't be cast to AcDbAttributeDefinition.

The file may be in use or has the read-only attribute set".

I have ensured that the file is not in use anywhere else, and that it does not have 'Read-Only' checked off in Windows Explorer File Properties.

I thought I should check in with you guys as I don't have the first clue of where to start.

Comments

  • Is the file by any chance located on a Network Shared Drive?
    Try locally. If that works then set your drive to the trusted windows zone.
    (Internet properties > Security: local Intranet > Sites > Advanced)
    here add file://ipaddress-of-your-shared-folder

  • Roy Klein Gebbinck
    edited November 2018

    Maybe using the _Audit command can fix things. The first part of the message seems to indicate an issue with the dwg itself.

  • I tried moving it to my C:/ drive and I also tried using the Audit command. The issue still persists.

    Thank you regardless.

  • Does SaveAs work?

    Can you share the drawing (or a slimmed down version of it, where the issue still exists)?

  • Did you change your location to save? or you can check the hidden file in this folder. I think it could be worked

  • I have the same issue.
    The original DWG was in the network. I got this error, audit and local saveas didnt work.
    It's not the first time this happened to me.
    The DWG was made in Autocad.
    I am using Bricscad 2020.

  • Same problem here. My boss had that same issue in a different file. Can't save. Did somebody find out a fix for it?
Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!