How to crop out excess space in my .dwg file?

Hi guys,

Total noob question here: when I zoom out, I get this view:

This affects me, when trying to print on e.g. an A4 format.
How could I crop this out, so that only the area of the drawing is still there.

Or should I copy and paste into a new file? No idea how to do this.

Thanks a lot!



  • Do you mean when you Zoom>Extents it zooms way out like this? Means there's element(s) way out from your working area, which Brics is zooming to include within 'extents'. They need deleting, unless they are insertion points for a Block or something.
  • Yes indeed, it zooms way out...
    But I don't seem to find elements in that space...

    Is there a way to find the insertion points?
  • Michael Mayer
    edited May 2023
    Does this help ?

    I tried it for the first time.
    But in my BIM File it shows/finds only objects, not only perfectly inside
    the green area, but basically just in my building !?

    Edit :
    I work in meters. Reducing green valid area to 1000 m or 1 km
    moving the left corner from origin by negative 10 m in XYZ
    showed no more "outliers"

    (Maybe in the first test it found Walls that extend below Z = 0.00.
  • Anthony Apostolaros
    edited May 2023
    In my older version of Bricscad, Zoom Extents doesn't include remote insertion points in the things that it zooms to. But it does include any remote objects that are in the block but on layers that are turned off or frozen.

    Turn on and thaw all layers, and then make a Crossing selection of the area where you can't find any objects. That will select any objects that are too small to see (or in a color that doesn't contrast enough with the background color) but are in a block and too far from everything else in the block to be selected by a Window selection.
Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. Click one of the buttons on the top bar to get involved!